[srslte-users] SoapySDR package not being found

Burt Gordon burt.gordon at systeminnovationgroup.com
Thu Aug 30 13:00:39 UTC 2018


Hello,

I have installed the SoapySDR package installed in an Ubuntu 18.04 Linux machine. However, when I run the cmake configurator the configuration comes back as saying it can't find the SoapySDR package so the srsUE executable is not being built. Is there a way to force it to see the package or is there a change to how it should be detected on Ubuntu 18?

Here is the SoapySDR output:
$ SoapySDRUtil --info
######################################################
## Soapy SDR -- the SDR abstraction library
######################################################

Lib Version: v0.6.1-2
API Version: v0.6.0
ABI Version: v0.6
Install root: /usr
Search path: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6
Search path: /usr/local/lib/x86_64-linux-gnu/SoapySDR/modules0.6
Search path: /usr/local/lib/SoapySDR/modules0.6
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libHackRFSupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libLMS7Support.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libRedPitaya.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libairspySupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libaudioSupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libbladeRFSupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libosmosdrSupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libremoteSupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/librtlsdrSupport.so
Module found: /usr/lib/x86_64-linux-gnu/SoapySDR/modules0.6/libuhdSupport.so
Loading modules... linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

Done

Here are the pertinent lines of the output of the cmake. I deleted the contents of the build folder a couple of times too just to make sure it was doing a reevaluation every time.

$ cmake ../
-- The C compiler identification is GNU 7.3.0
-- The CXX compiler identification is GNU 7.3.0
-- Check for working C compiler: /usr/bin/cc
<snip>
-- FINDING SOAPY.
-- Checking for module 'SoapySDR'
--   No package 'SoapySDR' found
-- libSOAPYSDR not found.
<snip>
-- srsUE and srsENB builds disabled due to missing RF driver


Any help?

Thanks,

Burt
Sr. System Innovator
www.SystemInnovationGroup.com<http://www.SystemInnovationGroup.com>
321-345-7670

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180830/6735e4b7/attachment-0001.html>


More information about the srslte-users mailing list