[srslte-users] srsenb failed to find device

Pedro Alvarez pedro.alvarez at softwareradiosystems.com
Mon Aug 13 14:28:14 UTC 2018


Weiqi --

Regarding the startup failure of the EPC, it seems that the setup of
the TUN interface for the SGi interface is failing.
If you send the epc.log, we might get more information on what went wrong.

Cheers,
Pedro

On Tue, Aug 7, 2018 at 1:45 PM, <wyao at corrections.com> wrote:
>
> Hi Yeats,
>
>
>
> Thanks for your reply, but my X300 and the srslte docker container is talking through a switch, not USB port. Also, I should states this before, I couldn’t get my srsepc working also, here is the output:
>
> “””
>
> root at srslte:~/.srs# srsepc
>
>
>
> ---  Software Radio Systems EPC  ---
>
>
>
> Reading configuration file /root/.srs/epc.conf...
>
> HSS Initialized.
>
> MME GTP-C Initialized
>
> MME Initialized.
>
> Could not initialize the SGi interface.
>
> Error initializing SP-GW
>
> “””
>
> Also, I tried add the radio type to the enb.conf, and still the srsenb gives me the same error.
>
> Appreciate for your help.
>
>
>
> Thanks,
>
> Weiqi
>
>
>
> From: Yeats Luo <yeatsluo at ghtinc.com>
> Sent: Monday, August 6, 2018 5:28 AM
> To: Andre Puschmann <andre.puschmann at softwareradiosystems.com>; wyao at corrections.com; srslte-users at lists.softwareradiosystems.com
> Subject: RE: [srslte-users] srsenb failed to find device
>
>
>
> I use USRP B210, and srsenb fails to find the device once for a while after execution.
>
>
>
> My approach is to write a script to soft-reset my USB 3.
>
> Works most of the time, if this fails, the final approach is to unplug the device and plug it again.
>
>
>
> I think soon or later this should be enlisted as an issue for the devs to solve.
>
>
>
> > Resetusb.sh
>
>
>
> #!/bin/bash
>
> for i in /sys/bus/pci/drivers/xhci_hcd/*:*; do
>
>   [ -e "$i" ] || continue
>
>   echo "${i##*/}" > "${i%/*}/unbind"
>
>   echo "${i##*/}" > "${i%/*}/bind"
>
> done
>
>
>
> Yeats Luo
>
> RD Consultant
>
> Tel: 0910199166
>
> Fax:(02)2361-7627
>
>
>
>
>
>
>
> From: Andre Puschmann
> Sent: 2018年8月6日 下午 05:24
> To: wyao at corrections.com; srslte-users at lists.softwareradiosystems.com
> Subject: Re: [srslte-users] srsenb failed to find device
>
>
>
> Hey,
>
>
>
> for the X310, also add "type=x300" to the device args.
>
>
>
> Hope that helps.
>
>
>
> Cheers
>
> Andre
>
>
>
>
>
>
>
> On 03/08/18 17:37, wyao at corrections.com wrote:
>
> > Hello everyone,
>
> >
>
> >
>
> >
>
> > I am new to this srsLTE project, and I have a Ettus X300 radios, which I
>
> > want to utilized srsenb to get the radio transmit.
>
> >
>
> >
>
> >
>
> > I build my srsLTE environment in a docker container, and when I try
>
> > srsenb I got following ouput(10.10.210.141 is my Ettus X300 device ip):
>
> >
>
> > ============================================================
>
> >
>
> > root at srslte:~# srsenb
>
> >
>
> > linux; GNU C++ version 5.4.0 20160609; Boost_105800;
>
> > UHD_003.009.007-0-g50839059
>
> >
>
> >
>
> >
>
> > Warning: Failed to create thread with real-time priority. Creating it
>
> > with normal priority: No such file or directory
>
> >
>
> > Warning: Failed to create thread with real-time priority. Creating it
>
> > with normal priority: No such file or directory
>
> >
>
> > ---  Software Radio Systems LTE eNodeB  ---
>
> >
>
> >
>
> >
>
> > Reading configuration file /root/.srs/enb.conf...
>
> >
>
> > Opening USRP with args: addr=10.10.210.141,master_clock_rate=30.72e6
>
> >
>
> > Error opening UHD: code 11
>
> >
>
> > Error opening RF device
>
> >
>
> > Failed to find device UHD with args addr=10.10.210.141
>
> >
>
> > ===========================================================
>
> >
>
> >
>
> >
>
> > I can ping the 10.10.210.141, and also I can do “uhd_usrp_probe --args
>
> > addr=10.10.210.14” with no problem in srslte docker. However, when I do
>
> > uhd_find_device, I couldn’t find any device. Have anyone setup a similar
>
> > environment before?  Please advise. Thanks and appreciate!
>
> >
>
> >
>
> >
>
> > Regards,
>
> >
>
> > Weiqi
>
> >
>
> >
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > _______________________________________________
>
> > srslte-users mailing list
>
> > srslte-users at lists.softwareradiosystems.com
>
> > http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
>
> >
>
>
>
> _______________________________________________
>
> srslte-users mailing list
>
> srslte-users at lists.softwareradiosystems.com
>
> http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
>
>
>
>
> _______________________________________________
> srslte-users mailing list
> srslte-users at lists.softwareradiosystems.com
> http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
>


More information about the srslte-users mailing list