[srslte-users] srsenb started correctly but can't find anyradio signal

Yeats Luo yeatsluo at ghtinc.com
Wed Aug 1 08:57:18 UTC 2018


Dear Xavier:

I finally let srsLTE to pickup radio signals and start attaching process, 
but the result is not successful so far. 
I would like to get some help by looking into the log file and explain what's the error "Malformed Packet" in pcap.

The UE is huawei dongle which is proven working with other ENB and passed the NAS authentication. 
So I guess the issue is focused on the RF side.

Any light in how to tune the enb is welcomed.

Yeats Luo
RD Consultant
Tel: 0910199166
Fax:(02)2361-7627
 
 

From: Yeats Luo
Sent: 2018年8月1日 下午 12:10
To: Xavier Arteaga
Cc: srslte-users at lists.softwareradiosystems.com
Subject: RE: [srslte-users] srsenb started correctly but can't find anyradio signal

Sorry for keep throwing questions.

UHD driver is now 3.13.
srsLTE branch: master, commit 470953bf9c5875646e4d5049c8f213d202fa84fd

issues: 
1. Can’t start GUI, it keeps saying “Trying to start a plot but plots are disabled (ENABLE_GUI constant in phch_worker.cc)”
But it’s confirmed libsrsgui.so is linked and compiled without error.
2. No signal.  STDOUT shows this and like doing nothing forever.  (Question: how to tune signal power in enb.conf ? and how to see power response without GUI?)

---  Software Radio Systems LTE eNodeB  ---

Reading configuration file /root/.srs/enb.conf...
[INFO] [UHD] linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_3.13.0.0-release
Opening USRP with args: type=b200,master_clock_rate=30.72e6
[INFO] [B200] Detected Device: B210
[INFO] [B200] Operating over USB 3.
[INFO] [B200] Initialize CODEC control...
[INFO] [B200] Initialize Radio control...
[INFO] [B200] Performing register loopback test...
[INFO] [B200] Register loopback test passed
[INFO] [B200] Performing register loopback test...
[INFO] [B200] Register loopback test passed
[INFO] [B200] Asking for clock rate 30.720000 MHz...
[INFO] [B200] Actually got clock rate 30.720000 MHz.
Setting frequency: DL=1870.0 Mhz, UL=1775.0 MHz
[INFO] [B200] Asking for clock rate 11.520000 MHz...
Trying to start a plot but plots are disabled (ENABLE_GUI constant in phch_worker.cc)
[INFO] [B200] Actually got clock rate 11.520000 MHz.
Setting Sampling frequency 11.52 MHz

3. The execution screws USRP USB, after terminating the program, the USB must be pulled off and re-plugged to resume work.  
       If not, STDOUT shows a lot of errors repeating.

USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLError receiving from UHD: 30
USRP reported the following error: None
LLLLLLError receiving from UHD: 30
USRP reported the following error: None



==== eNodeB started ===
Type <t> to view trace

Have a nice day
Yeats Luo
RD Consultant
Tel: 0910199166
Fax:(02)2361-7627
 
 

From: Xavier Arteaga
Sent: 2018年7月23日 下午 04:01
To: Yeats Luo
Cc: srslte-users at lists.softwareradiosystems.com
Subject: Re: [srslte-users] srsenb started correctly but can't find any radio signal

Hi Yeats,
I am sorry to read that.

I saw you are using UHD 3.12, could you try with UHD 3.9? I use the UHD Long Term Support PPA.

Crossed fingers you have it working soon.

Regards,
Xavier


On 23 July 2018 at 04:18, Yeats Luo <yeatsluo at ghtinc.com> wrote:
 
Thanks for the tips.
I tried this,
device_args = otw_format=sc12
and also tried this,
device_args = type=b200,otw_format=sc12,num_recv_frames=64,num_send_frames=64
 
Shows error messages as below.  Hope to have further suggestion.  Thanks.
 
A lot of :
[ERROR] [STREAMER] The receive packet handler caught a value exception.
ValueError: bad vrt header or packet fragment
Error code 0xf was returned during streaming. Aborting.
[ERROR] [STREAMER] The receive packet handler caught a value exception.
ValueError: bad vrt header or packet fragment
Error timed out while receiving samples from UHD.
Error code 0xf was returned during streaming. Aborting.
 
And a log of:
LLLLLLLLLLLLLLLLLLError timed out while receiving samples from UHD.
LLLLLLLLLLLLLLLLLLError timed out while receiving samples from UHD.
LLLLLLLLLLLLLLLLLLError timed out while receiving samples from UHD.
…..
….
 
Yeats Luo
RD Consultant
Tel: 0910199166
Fax:(02)2361-7627
 
 
 
寄件者: Xavier Arteaga
傳送時間: 2018年7月20日 下午 08:49
收件者: Yeats Luo
副本: srslte-users at lists.softwareradiosystems.com
主旨: Re: [srslte-users] srsenb started correctly but can't find any radio signal
 
Hi Yeats,
Can you append "otw_format=sc12" to device_args in enb.conf?
 
Let me know how it goes.
 
Regards,
Xavier
 
On 20 July 2018 at 09:37, Yeats Luo <yeatsluo at ghtinc.com> wrote:
The attached picture shows that there’s no radio signal picked.
What did I miss ?
 
Yeats Luo
RD Consultant
Tel: 0910199166
Fax:(02)2361-7627
 
 
 
寄件者: Yeats Luo
傳送時間: 2018年7月20日 下午 12:38
收件者: srslte-users at lists.softwareradiosystems.com
主旨: srsenb started correctly but can't find any radio signal
 
I configured a srsENB  with USRP B210 antenna, to connect to nextEPC in another machine.
Everything runs fine without any error message, however, the RF signal seems to be a flat line ( a single dot in the GUI QAM chart)
Of course, none of my mobile device can find a working service provider on air.
How do I trace the problem like this ?
 
 
UHD benchmark succeeded without any error
TX Summary: Frequency Range: 50.00 MHz - 6000.00 MHz (Step: 100.00 MHz) 
Gain Range: 0.00 - 89.75 (Step: 1.00) 
USRP successfully tuned to all frequencies. 
LO successfully locked at all frequencies. 
USRP successfully set all specified gain values at all frequencies. 
 
RX Summary: Frequency Range: 50.00 MHz - 5950.00 MHz (Step: 100.00 MHz) 
Gain Range: 0.00 - 76.00 (Step: 1.00) 
USRP successfully tuned to all frequencies. 
LO successfully locked at all frequencies. 
USRP successfully set all specified gain values at all frequencies.
 
Console
root at enb118:~/.srs# srsenb
---  Software Radio Systems LTE eNodeB  ---
 
Reading configuration file /root/.srs/enb.conf...
[INFO] [UHD] linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_3.12.0.0-release
Opening USRP with args: type=b200,master_clock_rate=30.72e6
[INFO] [B200] Detected Device: B210
[INFO] [B200] Operating over USB 3.
[INFO] [B200] Initialize CODEC control...
[INFO] [B200] Initialize Radio control...
[INFO] [B200] Performing register loopback test...
[INFO] [B200] Register loopback test passed
[INFO] [B200] Performing register loopback test...
[INFO] [B200] Register loopback test passed
[INFO] [B200] Asking for clock rate 30.720000 MHz...
[INFO] [B200] Actually got clock rate 30.720000 MHz.
[INFO] [MULTI_USRP]     1) catch time transition at pps edge
[INFO] [MULTI_USRP]     2) set times next pps (synchronously)
[ERROR] [STREAMER] recv packet demuxer unexpected sid 0xfe7803a1
[ERROR] [STREAMER] recv packet demuxer unexpected sid 0xffdf0072
Setting frequency: DL=1842.5 Mhz, UL=1747.5 MHz
[INFO] [B200] Asking for clock rate 23.040000 MHz...
Starting plot for worker_id=0
[INFO] [B200] Actually got clock rate 23.040000 MHz.
Setting Sampling frequency 23.04 MHz
 
==== eNodeB started ===
Type <t> to view trace
DDDDLLLLLLLLLLLLLLLLLLLLLLt
Enter t to stop trace.
 
 
Enb.conf
[enb]
enb_id = 0x19B
cell_id = 0x01
phy_cell_id = 1
tac = 0x0001
mcc = 208
mnc = 93
mme_addr = 192.168.100.207
gtp_bind_addr = 192.168.100.118
s1c_bind_addr = 192.168.100.118
n_prb = 100
tm=4
nof_ports=2
 
[rf]
dl_earfcn = 1575
 
 
 
enb.log
12:30:26.453639 [PHY0] [I] [00000] Worker 0 configured cell 100 PRB
12:30:26.780562 [PHY1] [I] [00000] Worker 0 configured cell 100 PRB
12:30:26.790367 [MAC ] [I] [00000] Resetting MAC
12:30:26.790992 [RRC ] [I] Allocating 2 PRBs for PUCCH
12:30:26.794078 [S1AP] [I] Connecting to MME 192.168.100.207:36412
12:30:26.795161 [GTPU] [D] Waiting for read...
12:30:26.795267 [S1AP] [I] SCTP socket established with MME
12:30:26.795394 [S1AP] [I] Sending s1SetupRequest
             0000: 00 11 00 2d 00 00 04 00 3b 00 08 00 02 f8 39 00
             0010: 00 19 b0 00 3c 40 0a 03 80 73 72 73 65 6e 62 30
12:30:26.800858 [S1AP] [I] Received S1AP PDU
             0000: 20 11 00 17 00 00 02 00 69 00 0b 00 00 02 f8 39
             0010: 00 00 00 02 00 01 00 57 40 01 ff
12:30:26.800895 [S1AP] [I] Received S1SetupResponse
12:30:27.442958 [PHY0] [I] [00000] Starting RX/TX thread nof_prb=100, sf_len=23040
12:30:27.443163 [RF  ] [W] Overflow
12:30:27.443176 [RF  ] [W] Overflow
12:30:27.643245 [RF  ] [W] Overflow
12:30:27.643271 [RF  ] [W] Overflow
12:30:27.644250 [PHY0] [D] [00000] Settting TTI=10236, tx_mutex=0, tx_time=0:0.004000 to worker 0
12:30:27.644640 [PHY0] [D] [10236] Worker 0 running
12:30:27.644779 [MAC ] [D] [00004] Allocating PUCCH (98,100)
12:30:27.645011 [PHY0] [D] [10236] Sending to radio
12:30:27.645252 [RF  ] [W] Late
12:30:27.645283 [RF  ] [W] Late
12:30:27.645325 [PHY0] [D] [10236] Settting TTI=10237, tx_mutex=1, tx_time=2:0.136233 to worker 1
12:30:27.645361 [RF  ] [W] Late
12:30:27.645443 [RF  ] [W] Late
12:30:27.645498 [RF  ] [W] Late
12:30:27.645562 [RF  ] [W] Late
12:30:27.645605 [RF  ] [W] Late
12:30:27.645680 [RF  ] [W] Late
12:30:27.645698 [PHY1] [D] [10237] Worker 1 running
12:30:27.645724 [RF  ] [W] Late
12:30:27.645801 [RF  ] [W] Late
12:30:27.645816 [MAC ] [D] [00005] Allocating PUCCH (98,100)
12:30:27.645840 [RF  ] [W] Late
12:30:27.645848 [RF  ] [W] Late
12:30:27.645881 [RF  ] [W] Late
12:30:27.645889 [RF  ] [W] Late
12:30:27.645922 [RF  ] [W] Late
12:30:27.646029 [PHY1] [D] [10237] Sending to radio
12:30:27.646287 [PHY0] [D] [10236] Settting TTI=10238, tx_mutex=2, tx_time=2:0.137233 to worker 0
12:30:27.646301 [PHY0] [D] [10238] Worker 0 running
12:30:27.646401 [MAC ] [D] [00006] Allocating PUCCH (98,100)
12:30:27.646573 [PHY0] [D] [10238] Sending to radio
12:30:27.647173 [PHY0] [D] [10238] Settting TTI=10239, tx_mutex=3, tx_time=2:0.138233 to worker 1
12:30:27.647188 [PHY1] [D] [10239] Worker 1 running
12:30:27.647277 [MAC ] [D] [00007] Allocating PUCCH (98,100)
12:30:27.647435 [PHY1] [D] [10239] Sending to radio
12:30:27.648708 [PHY0] [D] [10238] Settting TTI=0, tx_mutex=4, tx_time=2:0.139233 to worker 0
12:30:27.648722 [PHY0] [D] [00000] Worker 0 running
12:30:27.648825 [MAC ] [D] [00008] Allocating PUCCH (98,100)
12:30:27.648988 [PHY0] [D] [00000] Sending to radio
12:30:27.649672 [PHY0] [D] [00000] Settting TTI=1, tx_mutex=5, tx_time=2:0.140233 to worker 1
12:30:27.649687 [PHY1] [D] [00001] Worker 1 running
12:30:27.649744 [PHY0] [D] [00000] Processing pending_tti=1
………..(forever reapeating)
 
 
 
 
 
Yeats Luo
RD Consultant
Tel: 0910199166
Fax:(02)2361-7627
 
 
 
 

_______________________________________________
srslte-users mailing list
srslte-users at lists.softwareradiosystems.com
http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
 
 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1B4B3ACF0C85490BA9A1BBD98BCE630A[770183].png
Type: image/png
Size: 4518 bytes
Desc: not available
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0001.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: enb.conf
Type: application/octet-stream
Size: 7067 bytes
Desc: not available
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0005.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: enb.log
Type: application/octet-stream
Size: 2092041 bytes
Desc: not available
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0006.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nextepc.conf
Type: application/octet-stream
Size: 6943 bytes
Desc: not available
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0007.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nextepc.log
Type: application/octet-stream
Size: 99043 bytes
Desc: not available
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0008.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: srslte-nextepc malformed packet.pcapng
Type: application/octet-stream
Size: 2276 bytes
Desc: not available
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20180801/828f59f4/attachment-0009.obj>


More information about the srslte-users mailing list