[srslte-users] Segmentation Fault for srsUE tests

jan acosta acosta.janp at gmail.com
Tue Jul 18 02:59:07 UTC 2017


Hello,

I am getting a segmentation Fault for the ue_itf_test_sib1,
ue_itf_test_prach, and mac_test.  They all have very similar outputs as
below.  I'm not sure what the problem is.  Below is the gdb backtrace.

I'm using a B210 and when I ran benchmark_rate from uhd I am getting a
steady  30 MHz IO.

Please take a look.  Thanks.

Starting program:
/home/group/git-srsLTE/srsLTE/build/srsue/test/phy/ue_itf_test_sib1 -f
1.8425e9
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
linux; GNU C++ version 5.3.1 20151219; Boost_105800;
UHD_003.009.002-0-unknown

[New Thread 0x7fffeaba8700 (LWP 30802)]
[New Thread 0x7fffea3a7700 (LWP 30803)]
[Thread 0x7fffea3a7700 (LWP 30803) exited]
[Thread 0x7fffeaba8700 (LWP 30802) exited]
[New Thread 0x7fffeaba8700 (LWP 30818)]
[New Thread 0x7fffea3a7700 (LWP 30819)]
[Thread 0x7fffea3a7700 (LWP 30819) exited]
[Thread 0x7fffeaba8700 (LWP 30818) exited]
[New Thread 0x7fffeaba8700 (LWP 30820)]
[New Thread 0x7fffea3a7700 (LWP 30821)]
[Thread 0x7fffea3a7700 (LWP 30821) exited]
[Thread 0x7fffeaba8700 (LWP 30820) exited]
[New Thread 0x7fffeaba8700 (LWP 30822)]
[New Thread 0x7fffea3a7700 (LWP 30823)]
[Thread 0x7fffea3a7700 (LWP 30823) exited]
[Thread 0x7fffeaba8700 (LWP 30822) exited]
Opening USRP with args: type=b200
[New Thread 0x7fffeaba8700 (LWP 30824)]
[New Thread 0x7fffea3a7700 (LWP 30825)]
[Thread 0x7fffea3a7700 (LWP 30825) exited]
[Thread 0x7fffeaba8700 (LWP 30824) exited]
[New Thread 0x7fffeaba8700 (LWP 30826)]
[New Thread 0x7fffea3a7700 (LWP 30827)]
[Thread 0x7fffea3a7700 (LWP 30827) exited]
[Thread 0x7fffeaba8700 (LWP 30826) exited]
[New Thread 0x7fffeaba8700 (LWP 30828)]
[New Thread 0x7fffea3a7700 (LWP 30829)]
-- Detected Device: B210
-- Operating over USB 3.
[New Thread 0x7fffe9994700 (LWP 30830)]
-- Initialize CODEC control...
-- Initialize Radio control...
-- Performing register loopback test... pass
-- Performing register loopback test... pass
-- Performing CODEC loopback test... pass
-- Performing CODEC loopback test... pass
-- Asking for clock rate 16.000000 MHz...
-- Actually got clock rate 16.000000 MHz.
-- Performing timer loopback test... pass
-- Performing timer loopback test... pass
-- Setting master clock rate selection to 'automatic'.
-- Asking for clock rate 32.000000 MHz...
-- Actually got clock rate 32.000000 MHz.
-- Performing timer loopback test... pass
-- Performing timer loopback test... pass
[New Thread 0x7fffe9152700 (LWP 30831)]
[New Thread 0x7fffe8951700 (LWP 30832)]
[New Thread 0x7fffdbfff700 (LWP 30833)]
[New Thread 0x7fffdb7fe700 (LWP 30834)]
[New Thread 0x7fffdaffd700 (LWP 30835)]
Searching for cell...
Using Volk machine: avx2_64_mmx_orc
Found CELL ID: 1 CP: Normal  , CFO: -0.1 KHz.
Trying to decode MIB...
 - Cell ID:         1
 - Nof ports:       2
 - CP:              Normal
 - PRB:             50
 - PHICH Length:    Normal
 - PHICH Resources: 1
 - SFN:             0
BCH decoded
Initializating cell configuration...
Setting Sampling frequency 11.52 MHz
Setting TX/RX offset 120 samples, 10.42 us

Thread 20 "ue_itf_test_sib" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffdb7fe700 (LWP 30834)]
0x000000000042c43d in srsue::phch_recv::run_thread() ()
(gdb) bt full
#0  0x000000000042c43d in srsue::phch_recv::run_thread() ()
No symbol table info available.
#1  0x000000000042c889 in thread::thread_function_entry(void*) ()
No symbol table info available.
#2  0x00007ffff7bc16ba in start_thread (arg=0x7fffdb7fe700) at
pthread_create.c:333
        __res = <optimised out>
        pd = 0x7fffdb7fe700
        now = <optimised out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140736875980544,
-6364117732151880853, 1, 140737488345983,
                140736875981248, 140737488346128, 6364055058821321579,
6364135874915505003}, mask_was_saved = 0}}, priv = {
            pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0,
canceltype = 0}}}
        not_first_call = <optimised out>
        pagesize_m1 = <optimised out>
        sp = <optimised out>
        freesize = <optimised out>
        __PRETTY_FUNCTION__ = "start_thread"
#3  0x00007ffff63b33dd in clone () at
../sysdeps/unix/sysv/linux/x86_64/clone.S:109
No locals.
(gdb) quit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20170718/2d00e3b0/attachment-0001.html>


More information about the srslte-users mailing list