[srslte-users] srsue to oai enb + epc problem

Nicola Bui n.bui at northeastern.edu
Wed Aug 30 19:08:45 UTC 2017


No other conncetions on tun_srsue or at least none that I started or that I
know about.
How can I tell if the packets are dropped at the tun_srsue?
Any other thing I can try?

Thanks,

Nicola Bui
Senior Research Scientist
College of Computer and Information Science
202 West Village H
360 Huntington Avenue
Boston, MA 02115

On Wed, Aug 30, 2017 at 12:16 PM, Harsha Chenji <cjkernel at gmail.com> wrote:

> The packets might be getting dropped at the tun_srsue and hence it
> doesn't show up on your console. Could be because of the source
> IP/MAC.
>
> Do you have another active connections on the pc with tun_srsue? Try
> shutting them down...
>
> On Wed, Aug 30, 2017 at 11:18 AM, Nicola Bui <n.bui at northeastern.edu>
> wrote:
> > Hi Harsha,
> >
> > I think you are right.
> > The pings enter the tun_srsue interface (172.16.0.2) and exits the gtp0
> > (172.16.0.1) on the other side
> > The replies enter the gtp0 on the other side, but do not exit from the
> > tun_srsue interface
> >
> > with ip route I have two entries for 172.16.0.0/12:
> > 172.16.0.0/12 dev gtp0  proto static
> > 172.16.0.0/12 dev gtp0  proto kernel scope link src 172.16.0.1
> >
> > The spgw is on the localhost: 127.0.200.1
> >
> > Any other suggestion?
> >
> > Thanks,
> >
> > Nicola Bui
> > Senior Research Scientist
> > College of Computer and Information Science
> > 202 West Village H
> > 360 Huntington Avenue
> > Boston, MA 02115
> >
> > On Tue, Aug 29, 2017 at 11:38 PM, Harsha Chenji <cjkernel at gmail.com>
> wrote:
> >>
> >> We had this issue:
> >>
> >> 1. see if the pings are exiting the tun_srsue interface (using
> wireshark)
> >> 2. see if the pings are arriving at the other side of the tunnel on
> >> the epc (using wireshark)
> >> 3. repeat for ping replies
> >> 4. check if the routes are setup properly on the spgw/epc (using ip -r
> >> etc.).
> >>
> >> My guess is there's a subnetting/DHCP/static route problem on the spgw.
> >>
> >> On Tue, Aug 29, 2017 at 4:57 PM, Nicola Bui <n.bui at northeastern.edu>
> >> wrote:
> >> > Dear all,
> >> >
> >> > I am trying to have srsue connected to an openairinterface eNB (+
> EPC).
> >> > The setup is working and after the successful connection (RRC
> connection
> >> > and
> >> > Network Attachment) I can see the tun_srsue interface.
> >> > However I was not able to use the interface to ping any device on the
> >> > other
> >> > side of the link. Any suggestion about how to configure it?
> >> >
> >> > Thanks a lot,
> >> > Nicola Bui
> >> > Senior Research Scientist
> >> > College of Computer and Information Science
> >> > 202 West Village H
> >> > 360 Huntington Avenue
> >> > Boston, MA 02115
> >> >
> >> > _______________________________________________
> >> > srslte-users mailing list
> >> > srslte-users at lists.softwareradiosystems.com
> >> > http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
> >> >
> >
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20170830/3dcb5f2a/attachment-0001.html>


More information about the srslte-users mailing list