[srslte-users] send pings from srsUE

Ismael Gomez ismael.gomez at softwareradiosystems.com
Tue Aug 22 15:53:57 UTC 2017


Have you added the default route through the EPC (e.g. 192.168.2.1)?

You could try with tcpdump to see where packets go through or do not..

On Tue, 22 Aug 2017 at 17:52 Olivier Pavageau <
olivier.pavageau at telecom-paristech.fr> wrote:

> Hello,
>
> I'm fairly certain I've disabled frquency scaling on my end now. I've
> cleaned up some of the issues I had, but I still can't ping further than
> the 192.168.2.0/255 network. I managed to ping 8.8.8.8 with another
> virtual mobile on a different PC, and to surf the web with a real mobile,
> so I don't know why the MME would not route srsUE's traffic.
>
> Do you have any ideas on what I should try ?
>
> Thanks for your help !
>
> Olivier
>
> ----- Mail original -----
> De: "Olivier Pavageau" <olivier.pavageau at telecom-paristech.fr>
> À: "Ismael Gomez" <ismael.gomez at softwareradiosystems.com>
> Cc: "srslte-users" <srslte-users at lists.softwareradiosystems.com>
> Envoyé: Vendredi 18 Août 2017 11:33:37
> Objet: Re: [srslte-users] send pings from srsUE
>
> Hello Ismael,
>
> I am not sure wether my CPU clock is maxed out when running srsUE. I also
> am not sure wether I've disabled frequency scaling or not. Regarding the
> latter, the only parameter in the conf file that looks a bit like it is
> sfo_correct_disable, but I don't think that's what I'm looking for. How do
> I check both of these conditions ? I am using USB 3.
>
> Thanks for your help !
>
> Olivier
>
> ----- Mail original -----
> De: "Ismael Gomez" <ismael.gomez at softwareradiosystems.com>
> À: "Olivier Pavageau" <olivier.pavageau at telecom-paristech.fr>,
> srslte-users at lists.softwareradiosystems.com
> Envoyé: Vendredi 18 Août 2017 10:49:44
> Objet: Re: [srslte-users] send pings from srsUE
>
> Hi Olivier,
>
> I'll just comment on the "OOSync error" messages. That's a UHD overflow
> message. It means the CPU wan't able to process all samples. Make sure
> you've disabled frequency scaling and CPU clock is maxed out and that you
> are using USB 3.
>
> On Fri, 18 Aug 2017 at 10:38 Olivier Pavageau <
> olivier.pavageau at telecom-paristech.fr> wrote:
>
> > Hello Andre,
> >
> > I've made little to no progress on the ping front. I contacted people at
> > Amarisoft to help me solve the issue, but it certainly seems I'm lacking
> > some knowledge to understand where the problem lies. I did however ping
> > another mobile on the network (192.168.2.4, on another PC) and I was
> > impressed that it would wake up the mobile to ask the MME of the other
> > mobile's whereabouts (or any address in the subnetwork for that matter).
> >
> > I have not witnessed as many crashes as I did previously (I'm not testing
> > as many things as I did), though I often get "OOSync error." messages the
> > more I keep srsue running, that are sometimes followed by a seg fault.
> > Attached is the end of a log file, of a run that ended with a seg fault.
> > The log options were all_level = info, all_hex_limit = 32; it does end in
> > the middle of a line. Do you want a file with all_level = debug (I feel
> > like there's not a whole lot of information in the log I captured)?
> >
> > Thanks for your time !
> >
> > Regards,
> >
> > Olivier
> >
> > ----- Mail original -----
> > De: "Olivier Pavageau" <olivier.pavageau at telecom-paristech.fr>
> > À: srslte-users at lists.softwareradiosystems.com
> > Envoyé: Jeudi 10 Août 2017 15:35:30
> > Objet: send pings from srsUE
> >
> > Hello,
> >
> > I successfully attached an instance of srsUE (controlled by an USRP B210)
> > to an Amarisoft LTE eNodeB (controlled by an USRP N210). I am now trying
> to
> > send IP packets from srsUE to the rest of the world through the tun_srsue
> > interface. The only pings I've successfully exchanged were between the
> MME
> > (192.168.2.1, the PC with the USRP N210) and srsUE (192.168.2.2, the PC
> > with the USRP B210). I've tried telling my PC to use tun_srsue to send
> > pings, to no avail.
> >
> > I also have some problems with ./srsue crashing the more I use it, until
> I
> > reboot the USRP B210. I have not fiddled with sampling rate or
> > overclocking, could the problem come from here ?
> >
> > Thank you for help !
> >
> > Regards,
> >
> > Olivier_______________________________________________
> > srslte-users mailing list
> > srslte-users at lists.softwareradiosystems.com
> > http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
> >
> _______________________________________________
> srslte-users mailing list
> srslte-users at lists.softwareradiosystems.com
> http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20170822/f70c9e05/attachment.html>


More information about the srslte-users mailing list