[srslte-users] srsue using X310 giving Device "UHD" not found

Ismael Gomez ismael.gomez at softwareradiosystems.com
Fri Jun 3 06:40:42 UTC 2016


You have to set the master clock rate in the usrp args to 30.72 MHz

On Thu, 2 Jun 2016, 16:37 N El Ouni, <naceuramine at gmail.com> wrote:

> I did not meant to send the message since I did not finish it.
> I see an advance here but still, there is something I might be missing.
>
> Thanks.
>
>
> On Thu, Jun 2, 2016 at 10:35 AM, N El Ouni <naceuramine at gmail.com> wrote:
>
>> Thanks Ismael for the reply,
>>
>> I went back and I think I fixed my installation of:
>> srsgui, srsLTE then srsue.
>>
>> FYI to install srsLTE I used:
>>
>> cmake -DCMAKE_INSTALL_PREFIX=/raid/nae/srs/srsLTE_install/
>> -DUHD_LIBRARIES=/raid/nae/gnuradio/lib/libuhd.so
>> -DUHD_INCLUDE_DIRS=/raid/nae/gnuradio/include/uhd
>> -DVOLK_INCLUDE_DIRS=/raid/nae/gnuradio/include/volk/
>> -DVOLK_LIBRARIES=/raid/nae/gnuradio/lib/libvolk.so
>> -DSRSGUI_LIBRARIES=/raid/nae/srs/srsgui_install/lib/libsrsgui.so
>> -DSRSGUI_INCLUDE_DIRS=/raid/nae/srs/srsgui_install/include
>> -DBLADERF_INCLUDE_DIRS=/raid/nae/gnuradio/include
>> -DBLADERF_LIBRARIES=/raid/nae/gnuradio/lib/libbladeRF.so
>> -DOCTAVE_OCTAVE_LIBRARY=/usr/lib/x86_64-linux-gnu/octave/3.8.1/liboctgui.so
>> ..
>>
>> Anyways, now when running srsLTE example: " pdsch_ue -f 709e6 -a
>> "addr=usrp02" ", I get
>>
>> linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.git-202-g9e0861e1
>>
>> Opening RF device...
>> Opening USRP with args: addr=usrp02
>> -- X300 initialization sequence...
>> -- Determining maximum frame size... 1472 bytes.
>> -- Setup basic communication...
>> -- Loading values from EEPROM...
>> -- Setup RF frontend clocking...
>> -- Radio 1x clock:200
>> -- Initialize Radio0 control...
>> -- Performing register loopback test... pass
>> -- Initialize Radio1 control...
>> -- Performing register loopback test... pass
>> Trying to dynamically change Master clock...
>> Error: LTE sampling rates are not supported. Master clock rate is 200.0
>> MHz
>> Opening bladeRF...
>> Unable to open device: Invalid operation or parameter
>> No compatible RF frontend found
>> Error opening rf
>>
>> I am running a USRP X310 over 1Gb Ethernet.
>>
>> On the other hand, I tried the same example of srsue: "sudo
>> LD_LIBRARY_PATH=/raid/nae/gnuradio/lib/:$LD_LIBRARY_PATH ./ue
>> ue.conf.X310", I get:
>>
>> linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.git-202-g9e0861e1
>>
>> ---  Software Radio Systems LTE UE  ---
>>
>> Reading configuration file ue.conf.X310...
>> Using srsLTE version 001.002.000
>> Device "UHD" not found. Switching to auto mode
>> Opening USRP with args:
>> "addr=usrp02,recv_frame_size=9232,send_frame_size=9232"
>> -- Opening a USRP2/N-Series device...
>> Error opening UHD: code 70
>> Opening bladeRF...
>> Unable to open device: Invalid operation or parameter
>> No compatible RF frontend found
>> Error opening RF device
>>
>> I see an advance here
>>
>>
>> On Wed, Jun 1, 2016 at 9:20 AM, Ismael Gomez <
>> ismael.gomez at softwareradiosystems.com> wrote:
>>
>>> Can you paste the output of cmake command for srsLTE and srsUE? There
>>> seems to be some kind of conflict during the compilation and the UHD
>>> libraries weren't linked correctly.
>>>
>>> On Tue, 31 May 2016 at 22:08 N El Ouni <naceuramine at gmail.com> wrote:
>>>
>>>> I tried that but got:
>>>>
>>>> ---  Software Radio Systems LTE UE  ---
>>>>
>>>> Reading configuration file ue.conf.X310...
>>>> Using srsLTE version 001.002.000
>>>> Opening bladeRF...
>>>> Unable to open device: Invalid operation or parameter
>>>> No compatible RF frontend found
>>>> Error opening RF device
>>>> Failed to find device auto with args
>>>> "addr=192.168.12.2,recv_frame_size=9232,send_frame_size=9232"
>>>>
>>>>
>>>> On Tue, May 31, 2016 at 3:09 PM, Ismael Gomez <
>>>> ismael.gomez at softwareradiosystems.com> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> Can you try leaving device_name uncommented?
>>>>>
>>>>> On Tue, 31 May 2016 at 18:18 N El Ouni <naceuramine at gmail.com> wrote:
>>>>>
>>>>>> Hello,
>>>>>>
>>>>>> I had first installed srsLTE, srsgui and then srsue (while adding
>>>>>> them as deps).
>>>>>> I copied ue.conf.example to ue.conf.X310 and made changes to meet uhd
>>>>>> x310 device spec (IP @ 192.168.12.2):
>>>>>>
>>>>>> device_name = "UHD"
>>>>>> device_args =
>>>>>> "addr=192.168.12.2,recv_frame_size=9232,send_frame_size=9232"
>>>>>> time_adv_nsamples = auto
>>>>>> burst_preamble_us = auto
>>>>>>
>>>>>> However running sudo
>>>>>> LD_LIBRARY_PATH=.../gnuradio/lib/:$LD_LIBRARY_PATH ./ue ue.conf.X310
>>>>>>
>>>>>> I am getting:
>>>>>>
>>>>>> ---  Software Radio Systems LTE UE  ---
>>>>>>
>>>>>> Reading configuration file ue.conf.X310...
>>>>>> Using srsLTE version 001.002.000
>>>>>> Device "UHD" not found. Switching to auto mode
>>>>>> Opening bladeRF...
>>>>>> Unable to open device: Invalid operation or parameter
>>>>>> No compatible RF frontend found
>>>>>> Error opening RF device
>>>>>> Failed to find device "UHD" with args
>>>>>> "addr=192.168.12.2,recv_frame_size=9232,send_frame_size=9232"
>>>>>>
>>>>>> FYI, uhd_usrp_probe --args "addr=192.168.12.2"is successful.
>>>>>>
>>>>>> Regards,
>>>>>>
>>>>>> --
>>>>>>
>>>>>> Naceur El Ouni, M.Eng.
>>>>>>
>>>>>> Guest Researcher at NIST
>>>>>>
>>>>>> *C*ommunications Technology Laboratory
>>>>>>
>>>>>> *W*ireless Networks Division
>>>>>>
>>>>>> 100 Bureau Drive
>>>>>>
>>>>>> Gaithersburg, (MD) 20899
>>>>>> (301) 975-3353
>>>>>> _______________________________________________
>>>>>> srslte-users mailing list
>>>>>> srslte-users at lists.softwareradiosystems.com
>>>>>> http://www.softwareradiosystems.com/mailman/listinfo/srslte-users
>>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> Naceur El Ouni, M.Eng.
>>>>
>>>> Guest Researcher at NIST
>>>>
>>>> *C*ommunications Technology Laboratory
>>>>
>>>> *W*ireless Networks Division
>>>>
>>>> 100 Bureau Drive
>>>>
>>>> Gaithersburg, (MD) 20899
>>>> (301) 975-3353
>>>>
>>>
>>
>>
>> --
>>
>> Naceur El Ouni, M.Eng.
>>
>> Guest Researcher at NIST
>>
>> *C*ommunications Technology Laboratory
>>
>> *W*ireless Networks Division
>>
>> 100 Bureau Drive
>>
>> Gaithersburg, (MD) 20899
>> (301) 975-3353
>>
>
>
>
> --
>
> Naceur El Ouni, M.Eng.
>
> Guest Researcher at NIST
>
> *C*ommunications Technology Laboratory
>
> *W*ireless Networks Division
>
> 100 Bureau Drive
>
> Gaithersburg, (MD) 20899
> (301) 975-3353
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20160603/19a99b45/attachment-0001.html>


More information about the srslte-users mailing list