[srslte-users] After some testing, LIBUSB_TRANSFER_ERROR from uhd_rx_nogui

Enes ÜNAL aenesunal at gmail.com
Thu Jun 2 12:56:41 UTC 2016


It seems not applying args to radio solves the problem.

I just commented out "srslte/lib/rf/rf_uhd_imp.c:249".

Without setting args, I did not get any error while opening the radio,
however; srsUE sometimes hangs, and just quit.

Is setting frame_sizes the problem, or those somehow makes libusb not
working, or overflow on kernel buffers?

Hope it helps to resolve the issue,

Thanks,
Enes.

2 Haz 2016 Per, 09:51 tarihinde, Enes ÜNAL <aenesunal at gmail.com> şunu yazdı:

> Thanks for your response.
>
> Best,
> Enes.
>
> On Thu, Jun 2, 2016, 09:50 Ismael Gomez <
> ismael.gomez at softwareradiosystems.com> wrote:
>
>> Yes this is a known issue
>>
>> On Thu, 2 Jun 2016, 08:46 Enes ÜNAL, <aenesunal at gmail.com> wrote:
>>
>>> Hello dear srsLTE users,
>>>
>>> After multiple (not at the same time) runs of srsUE, I got
>>>
>>> ############
>>> Error opening RX stream: 44
>>> No compatible RF frontend found
>>> Error opening RF device
>>> Failed to find device auto with args auto
>>> ############
>>>
>>> Since the message is not descriptive enough, I tried to open official
>>> uhd application ie. uhd_rx_nogui. As I expected, it gave an error whatever
>>> the configuration. The error is as follows:
>>>
>>> ############
>>> thread[thread-per-block[0]: <block gr uhd usrp source (2)>]:
>>> RuntimeError: usb rx6 transfer status: LIBUSB_TRANSFER_ERROR
>>> ############
>>>
>>> When I tried to open uhd_rx_nogui multiple times, I could not generate
>>> the same error. It seems it's a libusb failure but libusb isn't whom
>>> responsible for the issue.
>>>
>>> I think the problem is originated from srsLTE, maybe wrong arguments or
>>> maybe unsuccessfully closed the libusb transfer stream.
>>>
>>> Is it a known issue, or am I the only one who saw it? The issue is gone
>>> everytime I plugged out USB and plugged in again.
>>>
>>> Thanks, Best.
>>> Enes.
>>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20160602/fc1a921c/attachment.html>


More information about the srslte-users mailing list