[srslte-users] srsGUI not found

Chiara c.capretti002 at studenti.unibs.it
Wed Jan 13 15:52:58 UTC 2016


Yes, I have done the installation on a new computer so I’m using the latest master version of both (srsLTE and srsGUI). 

I’ll try to understand what are the problems.

Thank you.

Best regards,
Chiara


> On 13 Jan 2016, at 16:49, Ismael Gomez <ismael.gomez at softwareradiosystems.com> wrote:
> 
> Do you have the latest master version? I just checked and itcompiles fine with and with out graphics. You should not manually modify CMakeCache. If it does not detect srsGUI you have to fix that, but not force manually the values in cache.
> 
> 
> On Wed, 13 Jan 2016, 16:37 Chiara <c.capretti002 at studenti.unibs.it <mailto:c.capretti002 at studenti.unibs.it>> wrote:
> yes, I did
> 
> 
>> On 13 Jan 2016, at 16:36, Ismael Gomez <ismael.gomez at softwareradiosystems.com <mailto:ismael.gomez at softwareradiosystems.com>> wrote:
>> 
>> Are you running cmake in a *new* build directory?
>> 
>> 
>> On Wed, 13 Jan 2016, 16:35 Chiara <c.capretti002 at studenti.unibs.it <mailto:c.capretti002 at studenti.unibs.it>> wrote:
>> I didn’t update the source code. 
>> 
>> When inside build directory I run 
>> 
>> cmake ../
>> 
>> I have
>> -- SRSGUI LIBRARIES SRSGUI_LIBRARIES-NOTFOUND
>> -- SRSGUI INCLUDE DIRS SRSGUI_INCLUDE_DIRS-NOTFOUND
>> — Could NOT find SRSGUI (missing: SRSGUI_LIBRARIES SRSGUI_INCLUDE_DIRS)
>> 
>> Best regards,
>> Chiara
>> 
>>> On 13 Jan 2016, at 15:48, Ismael Gomez <ismael.gomez at softwareradiosystems.com <mailto:ismael.gomez at softwareradiosystems.com>> wrote:
>>> 
>>> When you update de source code and rebuild you better remove CMakeCache or the entire build directory
>>> 
>>> 
>>> On Wed, 13 Jan 2016, 15:33 Chiara <c.capretti002 at studenti.unibs.it <mailto:c.capretti002 at studenti.unibs.it>> wrote:
>>> Hi all,
>>> 
>>> I have just repeated the installation of srsLTE and srsGUI but srsLTE doesn’t find srsGUI. I found probably an error on the CMakeCache file, where the variable SRSGUI_LIBRARIES and SRSGUI_INCLUDE_DIRS weren’t initialised.
>>> So I did:
>>> SRSGUI_INCLUDE_DIRS:PATH=/usr/local/include
>>> SRSGUI_LIBRARIES:FILEPATH=/usr/local/lib/srsgui.so
>>> 
>>> After that, when I run make I have got an error:
>>> 
>>> /home/lte/srsLTE/srslte/lib/sync/test/pss_file.c:341:27: fatal error: srsgui/srsgui.h: No such file or directory
>>> 
>>> What should I do?
>>> 
>>> Thank you very much.
>>> 
>>> Chiara
>>> --
>>> Informativa sulla Privacy: http://www.unibs.it/node/8155 <http://www.unibs.it/node/8155>
>>> _______________________________________________
>>> srslte-users mailing list
>>> srslte-users at lists.softwareradiosystems.com <mailto:srslte-users at lists.softwareradiosystems.com>
>>> http://www.softwareradiosystems.com/mailman/listinfo/srslte-users <http://www.softwareradiosystems.com/mailman/listinfo/srslte-users>
>> 
>> 
>> Informativa sulla Privacy: http://www.unibs.it/node/8155 <http://www.unibs.it/node/8155>
> 
> Informativa sulla Privacy: http://www.unibs.it/node/8155 <http://www.unibs.it/node/8155>

-- 
Informativa sulla Privacy: http://www.unibs.it/node/8155
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.softwareradiosystems.com/pipermail/srslte-users/attachments/20160113/8db3fbc3/attachment.html>


More information about the srslte-users mailing list